Community Add-Ons

Maintainers: wdepot
Add file to this package
Top » Features

update osCommerce 2.3.x to use mysqli
for osCommerce Online Merchant v2.3

Download
by wdepot / 20 Feb 2013

Since the mysql functions used in osCommerce 2 are deprecated and due for removal from PHP I have updated our version to use the equivalent mysqli procedural functions instead if the mysqli class is installed. If mysqli is not available the old mysql functions will still be used. This is just a simple way of future proofing your osCommerce install.

Note: Be absolutely certain that you perform install step 2a or you will not be able to log in to the admin side of your web site unless you have changed things so that sessions are stored someplace besides the database.

Legend:  Download   Report

Expand All / Collapse All

update osCommerce 2.3.x to use mysqli wdepot 20 Feb 2013  

Since the mysql functions used in osCommerce 2 are deprecated and due for removal from PHP I have updated our version to use the equivalent mysqli procedural functions instead if the mysqli class is installed. If mysqli is not available the old mysql functions will still be used. This is just a simple way of future proofing your osCommerce install.

Note: Be absolutely certain that you perform install step 2a or you will not be able to log in to the admin side of your web site unless you have changed things so that sessions are stored someplace besides the database.